Welcome to the Gsm Forum ShaarpMind.






+ Reply to Thread + Post New Thread
Results 1 to 2 of 2
  1. #1
    Member
    Join Date
    Feb 2011
    Posts
    10,306

    Thumbs up Customers iPhone 4* no signal after I replaced his screen* eeekkkk!


     
    I install about 2 iPhone 4 screens every week* usually they are totally fine and the phone works perfectly afterwards.


    About a week ago a customer came to me with an iPhone 4 he had dropped* both the front and rear screen were smashed* and the actual frame had gotten a little bent as well.


    I installed a new front screen and rear cover* however after I put the phone back together I didnt have a sim card and the customer didnt leave his one in there* so I didnt test it. He brought it back a day later and said the reception was not good. The phone would swap between one bar and No Signal* occasionally two or even three bars. It was obvious there was a problem.


    I took the phone apart and put it back together again to check that it wasnt a loose connection or a fault with installation. And bingo* five bars! I gave it back to him but after using it for five minutes he showed me it and again it had only 1 bar* we played with it for a while and it went up to 2 bars. His galfriends iPhone 4 on the same network had 5 bars right next to him.


    In the end I said I think its possibly a hardware fault due to the frame being bent and gave him the options of either replacing the frame or uninstalling the new screen and putting the old one back in so he could get money back.


    I thought this issue would have been due the iPhone having had a bent frame. I am of course aware of the issues with the iPhone 4 frame* antenna gate* if you hold it in a certain way it will loose reception. This wasnt what was happening.


    So now yesterday* I fixed a different customers iPhone 4. He too took out his sim card and I forgot to test the reception etc after the install was done. He called me this morning and said it had no reception after the install - hed run some field test App which stated -113db of reception. He said that even with the old broken screen the reception was fine.


    I want to quickly fix his phone when I visit him onsite today. So I am unsure whether I have just forgotten to plug something in (seems very unlikely...) or somehow installed the screen incorrectly? What could it be?


    I thought the install went very smoothly.




    What issues are associated with no signal or low signal after a screen replacement on an iPhone 4?



    This is the second time this has happened now* so I want to make sure its not something Im doing.


    Any help is much appreciated.

  2. #2
    Member
    Join Date
    Feb 2011
    Posts
    38,431

    Thumbs up Customers iPhone 4* no signal after I replaced his screen* eeekkkk!


     
    Problem solved.
    Customer just called me back and said he restored the software on the phone. Now its working. Most likely the carrier settings didnt update due to it not having a sim card in there when the customer restored the iPhone before I came so that he could return it to Apple if necessary* and thats why it wasnt working.
    System Solution - from now on test every single iPhone for network connection before giving it back to customer* and making sure to test it with a simcard if the customer has taken it out.


 
+ Reply to Thread

Similar Threads

  1. Replies: 9
    Last Post: 04-16-2012, 04:47 AM
  2. Replies: 0
    Last Post: 03-08-2012, 09:16 AM
  3. Replies: 6
    Last Post: 02-14-2012, 07:26 AM
  4. iPhone 4 low wifi signal after screen change
    By djkadiross in forum Hardware
    Replies: 11
    Last Post: 01-14-2012, 07:33 AM
  5. Replies: 3
    Last Post: 01-14-2012, 05:48 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts